Skip to main content

Android: An app is needed to use this device

I am trying to connect my hearing aids through the Bluetooth settings. I select LE_R or LE_L and keep getting a pop-up message: „An app is needed to use this device”. I already have an app. Why do I get this message?
MicrosoftTeams-image (12).png
Please use the myPhonak app to establish the connection between hearing aids and app. Instructions will be provided in the app. 

Phonak hearing aids use Bluetooth LE (Low Energy) to connect with the myPhonak app. LE_R and LE_L connection can be established only through the myPhonak app. The message „An app is needed to use this device” will appear each time when you try to connect to the Bluetooth LE through the Bluetooth settings. To establish this connection please open myPhonak app instead.